family tree maker banner

Frequently Asked Question

Why do we need upgrade to FTM 2019 ? If you haven’t use the feature to connect Family Tree Maker to Ancestry.com through FTM 2017, then you have to upgrade it to Family Tree Maker 2019 as Mackiev has already stop the sync of FTM 2014 and the older version. Does the new FTM 2019 …

Frequently Asked Question Read More »